Certbot error: ACMEv1 is deprecated and you can …

今天好友說有一個網站的 SSL 過期了,請小蛙幫忙看一下,下指令更新會出現 Certbot error: ACMEv1 is deprecated

使用免費的 SSL 就要承受每三個月過期一次的麻煩,但是想想三個月過期一次就可以省一大筆錢,似乎又還蠻划算的~之前遇到很多種奇怪的狀況,這篇記錄一下第一次遇到這種 ACMEv1。

小蛙覺得奇怪,怎麼去年三月到現在已經正常運行那麼久了,卻在這時候突然失靈,輸入 certbot run 的指令後出現 ACMEv1 is deprecated and you can bla bla bla 通常附上的連結點過去都沒什麼結果,直接把相關問題丟 Google 比較實在。

經過一番查詢後才知道原來是 certbot 的版本更新了,原本使用的 ACMEv1 已經不能使用,好友網站是 Ubuntu 16.04 LTS,更新也很簡單

apt-get install --only-upgrade certbot

期間可能會連帶更新例如 python3 等相依的套件,等他跑完就完成了!

網站架設系列文章:

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。